Degraded Performance Due to External Provider Outage

Incident Report for Pencil

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 14:53 UTC

Investigating

Some users may experience degraded performance and intermittent errors.
Cause: Multiple external vendors we rely on are currently experiencing outages stemming from an AWS incident.
We’re actively working to minimize impact and will update this page as the situation evolves. Thank you for your patience.
Posted Oct 20, 2025 - 09:48 UTC
This incident affected: app.trypencil.com, pro.trypencil.com, and Chargebee API (EU).